Question

Is my PPX2055 Mac compatible?

Answer

Yes, you can use your PPX2055 with Mac OS 10.6, 10.7, 10.8 or 10.9. You will just need to download the MAC version of the software from the Picopix support webpage "Software and drivers"

Was this document helpful?

Yes No Need to try first

Give us your feedback on this FAQ. What could we have done to to answer your question better?